网络安全动态 ·

Linux kernel内存破坏漏洞 (CVE-2020-14386) 预警

一、基本情况

近日,国外安全研究员披露Linux kernel存在内存破坏漏洞(CVE-2020-14386),该漏洞可以导致内存破坏、系统崩溃,成功利用该漏洞可获取ROOT权限。目前官方已发布修复版本,建议受影响用户尽快升级到Linux内核最新版本,做好资产自查以及预防工作,以免遭受黑客攻击。

二、漏洞等级

高危

三、漏洞详情

Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。

该漏洞洞存在Linux kernel 5.9-rc4之前版本中net/packet/af_packet.c文件中,由于packet_rcv函数在计算netoff时存在整数溢出漏洞,导致内存破坏,从而获取权限提升。该漏洞触发时需要本地低权限用户执行其具有执行权限的可执行文件,同时系统启用CAP_NET_RAW功能。

四、影响范围

Linux kernel <5.9-rc4

五、处置建议

1、通用修复建议

目前官方已发布修复版本,建议尽快升级到Linux内核最新版本。

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=acf69c946233259ab4d64f8869d4037a198c7f06

2、临时修复建议

对于暂时不能进行版本升级的用户,可采取禁用CAP_NET_RAW功能的方式来降低风险。

方法:setcap cap_net_raw-ep /bin/ping

六、参考链接

https://seclists.org/oss-sec/2020/q3/146

支持单位:

上海观安信息技术股份有限公司

天融信安全应急响应中心

深信服科技股份有限公司

声明:本文来自网络安全威胁信息共享平台,版权归作者所有。文章内容仅代表作者独立观点,不代表安全内参立场,转载目的在于传递更多信息。如有侵权,请联系 [email protected]

参与评论